Important macOS patch | Ghostery Midnight - 1.2.3

In 1.2.3, we’re releasing an important update that addresses the following issue:

  • Midnight versions 1.2.2 and prior will report an unidentified error if a user attempts to load it on macOS Big Sur. This version provides a notification explaining that Midnight is not currently supported and provides a button to check for updates.

Click here to download the latest version of Midnight

If you’re experiencing any issues, please don’t hesitate to reach out to support@ghostery.com.

Happy Browsing!