Epic Game Launcher Issues

Hi,

With Ghostery Midnight I’m having issues logging into and using Epic Games Store/Launcher.

I typically sign-in using my Google Account which opens a browser tab where it’s verified and then goes back to the app. With Midnight it verifies in the browser, goes back to the app, goes through the motions of signing-in then just returns to the login portion. Once I do manage to login* then re-enable Midnight, I’ll eventually get an error saying that Epic can’t connect if I try to download/update anything.

I’ve tried to set the Epic Game Launcher in ‘My Apps’ between Protected, Monitored, and Disabled but it doesn’t make a difference. I’ve also disabled ‘Tracker Protection’ and ‘Ad Blocking’ on Midnight, but it still gets blocked. Also, I tried multiple combinations. 'TP then ‘AB’ then ‘TP’ & ‘AB’ together, etc. *The only way I can login is if I completely Pause Midnight. Also, I’m not using the VPN.

Sorry if this is something really obvious I’m missing.

Edit: I’ve also tried Steam, completely different but in the same vein of apps, and I don’t have any problem regardless of the settings. At least initially.


The image is when I get logged in and then try to do something while in the app.

Hi @HeyHaz - Thanks for alerting us of this and providing such great details! Confirming I’m also having issues using the Epic Game App. We’ll take a look and hopefully come up with a resolution soon. Will keep you posted.

@melissa No problem. Also, I’ve ran into the same problem in another location. I use BlueStacks, which is an Android emulator, it works fine; however, the Google Play Store in BlueStacks has the same issue as Epic. Can’t seem to connect without pausing Midnight.

It also interferes with GOG app as well, the application will report that I’m offline and can’t connect to the store.